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Reporting Services

	Objectives

NOTE:  This lab focuses on the concepts in this module and as a result may not comply with Microsoft security recommendations.


	After completing this lab, you will be able to:

· Create a Report
· Create a Table Report
· Work with Reports

	Scenario
	Reporting Services is a key component in providing a complete data management platform for SQL Server users. This lab will teach you how to create different types of reports using Reporting Services and the SQL Server Business Intelligence Development Studio. It also covers managing security settings for these reports and the different deployment models available.

	Prerequisites
	· Basic working experience with the SQL Server Business Intelligence Development Studio
· Basic knowledge of SQL Server security features

	Estimated Time to Complete This Lab
	75 Minutes


Lab Setup

	Tasks
	Detailed Steps

	1. Log in.
	1. Log in using your account.

	2. Download Northwind
	2. Restore the Northwind SQL database using SQL Server 2005 Management Studio. See http://www.ssw.com.au/SSW/KB/KB.aspx?KBID=Q1784912 for instructions.


Exercise 1
Authoring a Basic Report
Scenario

In this exercise, you will create a simple report using Visual Studio. 

To create the report, you will:

· Create a Visual Studio solution and add a Report Project. 
· Create a tabular report with a document map. 
SQL Reporting Services report designer is hosted in the Visual Studio environment. It provides you with an integrated developer environment for designing, creating, testing, and debugging reports.
The Goal
By the end of the first 2 exercises you will have an interactive Reporting Services company sales report similar to the one below.

	Tasks
	Detailed Steps

	1. Launch the report design environment.
NOTE:  If the Solution Explorer pane is not visible, select View | Solution Explorer.
	1. From the Windows task bar, select Start | All Programs | Microsoft Visual Studio 2005 | Microsoft Visual Studio 2005. This can also be accessed through Start | All Programs | Microsoft SQL Server 2005 | SQL Server Business Intelligence Development Studio
Visual Studio provides the environment in which Reporting Services reports are designed.
2. Select File | New | Project.
3. In the New Project dialog box, in the Project types pane, verify that the Business Intelligence Projects folder is selected.
Visual Studio allows you to create a blank Visual Studio 2005 solution or to select one of the Business Intelligence templates such as Analysis Services Project, Integration Services Project, or Report Server Project.
4. In the Templates pane, click the Report Server Project icon.
5. In the Name box, type Sales Reports.
6. Uncheck Create directory for solution and then click OK.
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	2. Create a new report
	A new report can be created using the report wizard. 
1. Select Project | Add New Item.
2. In the Add New Item page, from the Templates pane, select Report, enter the name Employee Sales by Country.rdl and then click Add.

	3. Create a shared data source
SSNOTE:  Fields can be added to the other sections of the report either by using the Page and Group buttons or by dragging and dropping the fields into the appropriate boxes.
	3. Right-click Shared Data Sources and click Add New Data Source
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4. Click Edit… in the Shared Data Source window

5. In the Connection Properties dialog box, in the Server Name text box, type (local).
6. Under Log on to the server, select Use Windows Authentication.
7. In the Select or enter a database name drop-down list, select Northwind, and then click OK.
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8. Call the data source NorthwindData


	4. Set the report query
	1. Double click the Employee Sales By Country report in Solution Explorer

2. Click the Data tab

3. In the Dataset dropdown list, click <New Dataset…>
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4. In the Query string box, paste in the query from www.ssw.com.au/SSW/Events/2006UTS_BI/Resources/03_SRS/ReportingServices_Module2_Query1_v1.txt, or enter the following query.

SELECT DISTINCT Employees.Country, Employees.LastName, Employees.FirstName, Orders.ShippedDate, Orders.OrderID, [Order Subtotals].Subtotal AS SaleAmount

FROM Employees INNER JOIN (Orders INNER JOIN [Order Subtotals] ON Orders.OrderID = [Order Subtotals].OrderID) ON Employees.EmployeeID = Orders.EmployeeID

5. Call it EmployeeSales. Click OK to close.
[image: image5.png]Query | ikt | e Optos | Paraeters | iters |

e
[enpivessas

Data source:

rertwindosta Ghaes) |

Command type!

frox =
Query g

Sibotds) Sebotal A5 SaEATeu: =
FROM Employees INNER JOIN (Orders INNER JOIN [Order Subtotals]

ON Orders,OrderID = [Order Subtotals].OrderID) ON

Enpioyces EMplorestt = G EnpiyeetD

Tineaut:

o | |)





6. Test that you are getting a result set by clicking the [image: image6.bmp] button

	5. Modify the Report Layout
	You will begin by creating a simple table report.

1. Click the Layout tab [image: image7.png]Layout



 in the report
2. From the ToolBox, drop a Table [image: image8.png]|[] Table



 onto the designer
3. Click the DataSets tab (located next to the ToolBox tab) in the bottom left of the screen
4. Drag the OrderID and SaleAmount fields into the Table Details row of the table
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5. Set the SaleAmount value cell to be formatted as currency by setting the Format property to c
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6. Add a new column to the table (right-click table header -> Insert column to the right)

7. Give it the heading Percent of Salesperson’s Total
8. In the details row, enter the value:

=ReportItems!SaleAmount.Value/Sum(Fields!SaleAmount.Value)
9. Set the Format property of the value cell to p (for percentage)
10. Preview the report by clicking the Preview tab. Notice the formatting and calculated fields.

11. Return to Layout mode. Click Report->Page Header from the menu.
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12. Add in some header information (company name, report description) to the header section of the report and preview it. Notice how it appears on every report page.



Exercise 2
Enhancing Basic Reports
Scenario

In this exercise, you will extend the original sales report to include:

· Conditional formatting

· Aggregate fields

· A document map

	Tasks
	Detailed Steps

	1. Add Grouping by Country
	Now you need to extend the sales report, which is grouped by country, and then by sales person in each country.

1. Open your Employee Sales By Country report

2. Click the Layout tab

3. Right-click the EmployeeSales dataset and add a calculated field called FullName with value:

=Fields!LastName.Value & ", " & Fields!FirstName.Value
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4. You now need to group the figures by country. Add a List [image: image14.bmp] to the body of the form. Set its Name property to CountryGroup
5. Drag and drop the table you created in Exercise 1 onto the List

6. Resize the list so it fills the whole body of the report. Your report will now look similar to the one below.
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7. Click the CountryGroup list. Click the ellipsis [image: image16.bmp] button next to its Grouping property
8. Select =Fields!Country.Value from the list (you are telling the list to group by country 
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9. In the Sorting tab, select =Fields!Country.Value for the Expression. Leave it in Ascending order. Click OK.
10. Add a TextBox above the table, but still within the CountryGroup list. Give it the value

="Country: " & Fields!Country.Value
11. Preview the report. Notice how the data is now grouped by country. 


	2. Add Grouping by Salesperson
	Now you need to further group the report by salesperson.
1. Drop another List onto the report (make sure it is inside the CountryGroup list). Give it the Name SalespersonGroup
2. Set the Grouping for the list to =Fields!FullName.Value and the sorting to the same
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3. Drag the table onto the SalespersonGroup List (because the records will be grouped by Salesperson as well as Country)

4. Add a TextBox to the form above the table but still inside the SalespersonGroup List. Set its value to =Fields!FullName.Value.
[image: image20.png]Page Header

SSW

oy

Cormpany sales breakdown by country and salesperson

ountry: * & Fields!Country v

a
D=FieldsIFullName.Value
a

Order ID
=FieldslOrderlD. Value

o
o
o

Sale Amount|  Percent of Salesperson’s

=Fields!SaleAmount Value =Reportitems!SaleAmount Valu




5. Preview the report. Notice how the sales amounts are now grouped by Salespersons in each Country.

6. Return to the Layout. At the bottom of the SalesPerson list, add a TextBox named SalesPersonTotal with value:

=Sum(Fields!SaleAmount.Value)
7. Set the Format property of the TextBox to c (currency)
8. Add a textbox to the left of it with name SalesPersonTotal and value:

="Total for " & Fields!FullName.Value & ": "
9. Preview the report. Notice the total per Salesperson is shown.

	3. Add in totals per country
	In a national sales report you would likely want to know the sales performance per country.

1. Add a textbox at the bottom of the CountryGroup list (outside of the SalespersonGroup list) with value:
 ="Total for: " & Fields!Country.Value
3. Add a TextBox to the right of it with value:
=Sum(Fields!SaleAmount.Value)

4. Format the aggregate field in step 2 as currency (set Format property to c)

5. Preview the report (you may need to jump ahead a few pages to see the total per country)
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	4. Add conditional formatting
	Now you will add a feature to the report so that you can tell at a glance whether a certain salesperson exceeded their sales target.
1. Return to Layout mode

2. To the right of the Salesperson name TextBox, add another Textbox with Value Exceeded Goal! Format it so it is bold, red and italicised (using the Font and Color properties)

3. Expand the Visibility property of the TextBox you created in step 2, and set the Hidden property to:

=iif(Sum(Fields!SaleAmount.Value) > 70000, False, True)
4. Preview the report. Notice how if the salesperson’s total sales did not exceed $70000 then the label is not displayed.

	5. Add a document map
	Now you will add navigation to the report which lets you quickly jump to a country

1. Return to Layout mode

2. Right-click the TextBox which displays the current country (i.e. in the top left of the CountryGroup List). Click Properties.

3. Under the Navigation tab, set Document map label and Jump to Bookmark: to =Fields!Country.Value . Click OK.
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4. Preview the document. Notice how you can jump between countries. Note: Document maps only provide 1 level of nesting – i.e. you cannot list Salespersons under their country, but you can list them on the same level as the countries.




Exercise 3
Manipulating Data Sets
Scenario

In this exercise, you will add parameters to the original sales report so that you can restrict the range of dates in the report.

	Tasks
	Detailed Steps

	1. Add date range parameters to the report
	1. Open the Employee Sales By Country report from Solution Explorer in the Data view

2. To the end of the query, add the following WHERE clause (in yellow)

SELECT DISTINCT Employees.Country, Employees.LastName, Employees.FirstName, Orders.ShippedDate, Orders.OrderID, [Order Subtotals].Subtotal AS SaleAmount

FROM Employees INNER JOIN (Orders INNER JOIN [Order Subtotals] ON Orders.OrderID = [Order Subtotals].OrderID) ON Employees.EmployeeID = Orders.EmployeeID

WHERE ShippedDate >= @pStartDate AND ShippedDate <= @pEndDate
3. Click outside of the query text window (like the results pane)

4. Click Report->Report Parameters… from the menu. Notice how the pStartDate and pEndDate parameters were automatically created for you. (if not, you will need to create them manually in this window and link them in the Parameters tab of the dataset’s properties)
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5. Select pStartDate from the list on the left and set its properties as shown below.
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6. Similarly, select pEndDate and set its properties as shown below, then click OK.
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7. Preview the report. Notice that at the top of the report there are 2 new parameters with date time selectors at the top with the default values you set. Try changing these values and clicking View Report to refresh the report with the new date range (hint: Northwind order data spans from 10/7/1996 to 6/5/1998)
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8. Now you want to show the date range on the report, so it is clearer to the user the range they are viewing. Return to Design view.
9. Add 4 TextBoxes to the top of the body of the report as shown below.

10. Format the second and fourth TextBoxes to be bold and red
11. Set the value of the second TextBox to be: =CDate(Parameters!pStartDate.Value).ToShortDateString
12. Set the value of the second TextBox to be:

   =CDate(Parameters!pEndDate.Value).ToShortDateString
13. Preview the report. Notice how the dates are displayed nicely in red at the top.
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